NanoVNA V2 / Forum

Note: this page is a mirror of https://groups.io/g/NanoVNAV2.
Click here to join and see most recent posts.

Nanosaver lock_up


Ambro_IW2FVO 2021/06/27 13:18

good day to all in this forum,
I am trying to use Nanosaver 0.3.8 together with NanoVNA V2-2 connected to my PC.. My PC runs windows_10_64 bits, has an Inter I_5 CPU and 8 GRAM.
I was able to connect and use the program just few times but now the program locks up as soos as the USB connect tab is pressed.
The program shows the correct USB port number and it agrees with the device manager. Is there a particule procedure  for connecting the USB ? The program shows " division by zero " somewhere.
I am attaching some screen captures to this mail.
Thanks in advance for any help.
regards
Bye

Siegfried Jackstien 2021/06/28 05:51

set avg to none and save in slot 0

program ask for say 100 points and you set device to avg x2 the soft
only gets 50 points

avg to none solves that

dg9bfc sigi

Am 27.06.2021 um 22:18 schrieb Ambro_IW2FVO via groups.io:

Ambro_IW2FVO 2021/06/28 07:26

thanks,I set avg to zero but still have the same problem.Could you please clarify what do you mean with " save to slot 0" ? I do not find any tabs for that.Bye
On Monday, June 28, 2021, 05:51:43 AM GMT+2, Siegfried Jackstien <siegfried.jackstien@freenet.de> wrote:


set avg to none and save in slot 0

program ask for say 100 points and you set device to avg x2 the soft only gets 50 points

avg to none solves that

dg9bfc sigi

Am 27.06.2021 um 22:18 schrieb Ambro_IW2FVO via groups.io:


good day to all in this forum,
I am trying to use Nanosaver 0.3.8 together with NanoVNA V2-2 connected to my PC.. My PC runs windows_10_64 bits, has an Inter I_5 CPU and 8 GRAM.
I was able to connect and use the program just few times but now the program locks up as soos as the USB connect tab is pressed.
The program shows the correct USB port number and it agrees with the device manager. Is there a particule procedure  for connecting the USB ? The program shows " division by zero " somewhere.
I am attaching some screen captures to this mail.
Thanks in advance for any help.
regards
Bye

Ambro_IW2FVO 2021/06/29 12:18

still NOT able to operate nanovna v2-2  with nanosaver ...Any additional help please ?Thanks.Bye
On Monday, June 28, 2021, 10:18:01 AM GMT+2, Ambro_IW2FVO via groups.io <iw2fvo=yahoo.com@groups.io> wrote:

thanks,I set avg to zero but still have the same problem.Could you please clarify what do you mean with " save to slot 0" ? I do not find any tabs for that.Bye
On Monday, June 28, 2021, 05:51:43 AM GMT+2, Siegfried Jackstien <siegfried.jackstien@freenet.de> wrote:


set avg to none and save in slot 0

program ask for say 100 points and you set device to avg x2 the soft only gets 50 points

avg to none solves that

dg9bfc sigi

Am 27.06.2021 um 22:18 schrieb Ambro_IW2FVO via groups.io:


good day to all in this forum,
I am trying to use Nanosaver 0.3.8 together with NanoVNA V2-2 connected to my PC.. My PC runs windows_10_64 bits, has an Inter I_5 CPU and 8 GRAM.
I was able to connect and use the program just few times but now the program locks up as soos as the USB connect tab is pressed.
The program shows the correct USB port number and it agrees with the device manager. Is there a particule procedure  for connecting the USB ? The program shows " division by zero " somewhere.
I am attaching some screen captures to this mail.
Thanks in advance for any help.
regards
Bye

Stan Holmes 2021/06/29 05:25

Are you using this HW version https://nanorfe.com/downloads/20210621/nanovna-v2-20210621-v2plus4.bin

Siegfried Jackstien 2021/06/29 14:28

you have set avg to none ok ...but... then you have to switch to
calibrate and save that in slot 0 (no need to do a full calibration just
the need to save the settings so the device knows that you want to use
avg=0)

there are a few memory slots for storing calibrations but slot 0 is used
as default when switching on so that is also used when you connect to usb

if you did not save the settings then it is not used when switching on
(or restarting like it does when connect to usb)

save the setings and it should work

greetz sigi dg9bfc

ps what fw version is on your device?!?

Am 29.06.2021 um 14:18 schrieb Ambro_IW2FVO via groups.io:

Ambro_IW2FVO 2021/06/29 14:14

Thanks a lot Siegfried,I am just a little in trouble trying to solve my problem> in the attached photo you will see the information about my nanovna.> as far as the Avg is concerned: are you talking about the nanosaver or about the nanovna devices ?>I can not find any  AVG setting tab  on my vna device> I can find out the avg setting on the saver program only
>>> could you please indicate to me the step by step procedure please ?     Is my nanovna firmware up to date ?
Thans again for the jelp.bye
On Tuesday, June 29, 2021, 02:28:50 PM GMT+2, Siegfried Jackstien <siegfried.jackstien@freenet.de> wrote:


you have set avg to none ok ...but... then you have to switch to calibrate and save that in slot 0 (no need to do a full calibration just the need to save the settings so the device knows that you want to use avg=0)


there are a few memory slots for storing calibrations but slot 0 is used as default when switching on so that is also used when you connect to usb

if you did not save the settings then it is not used when switching on (or restarting like it does when connect to usb)

save the setings and it should work


greetz sigi dg9bfc

ps what fw version is on your device?!?

Am 29.06.2021 um 14:18 schrieb Ambro_IW2FVO via groups.io:


still NOT able to operate nanovna v2-2  with nanosaver ... Any additional help please ? Thanks. Bye
On Monday, June 28, 2021, 10:18:01 AM GMT+2, Ambro_IW2FVO via groups.io <iw2fvo=yahoo.com@groups.io> wrote:

thanks, I set avg to zero but still have the same problem. Could you please clarify what do you mean with " save to slot 0" ? I do not find any tabs for that. Bye
On Monday, June 28, 2021, 05:51:43 AM GMT+2, Siegfried Jackstien <siegfried.jackstien@freenet.de> wrote:


set avg to none and save in slot 0

program ask for say 100 points and you set device to avg x2 the soft only gets 50 points

avg to none solves that

dg9bfc sigi

Am 27.06.2021 um 22:18 schrieb Ambro_IW2FVO via groups.io:


good day to all in this forum,
I am trying to use Nanosaver 0.3.8 together with NanoVNA V2-2 connected to my PC.. My PC runs windows_10_64 bits, has an Inter I_5 CPU and 8 GRAM.
I was able to connect and use the program just few times but now the program locks up as soos as the USB connect tab is pressed.
The program shows the correct USB port number and it agrees with the device manager. Is there a particule procedure  for connecting the USB ? The program shows " division by zero " somewhere.
I am attaching some screen captures to this mail.
Thanks in advance for any help.
regards
Bye

Ambro_IW2FVO 2021/06/29 16:56

this is my nanovna version.Do i have to change the firmware ?Thanks

On Tuesday, June 29, 2021, 04:48:40 PM GMT+2, Stan Holmes <zs6hal@gmail.com> wrote:

Are you using this HW version https://nanorfe.com/downloads/20210621/nanovna-v2-20210621-v2plus4.bin

Stan Holmes 2021/06/29 10:16

This is the version you should be using.
https://nanorfe.com/downloads/20201013/nanovna-v2-20201013-v2_2.bin

Vladimir Lebedev 2021/06/29 10:18

Hello Stan!

Ambro have a NORMAL V2_2 , NOT V2Plus4!

Vladimir

Stan Holmes 2021/06/29 10:22

Just sent him the correct version link for V2_2
https://nanorfe.com/downloads/20201013/nanovna-v2-20201013-v2_2.bin

Siegfried Jackstien 2021/06/29 22:35

avg in device can be found under "display" (trace, format, scale,
channel, AVG!!!!!, transform, flipdisplay, back)

click on avg and set that to none ... then on "back, another time on
back ... and you are in the main menue

now select calibrate (fourth from top) and save (second from top) ...
and save 0 ...

.... thats it

from your picture i see that you have still very old (outdated) firmware
on your device ... so thats another thing to solve (update your firmware!)

here latest "official" from owo (se added file)

dislord also wrote SEVERAL fw for the different devices (v2 small and
big lcd, v2plus with small and big display and for v2plus4 ... with and
without fpu) so i do not exactly know what is the last version from displord

i think it was "V2 320x240 noecal 301 points smooth.bin" ... but i am
not sure (hey dislord ... lend ambro a hand!! what was your last version
for the "normal" v2?!?!?)

some pc software have problems if you have not set avg to 0 ... soft ask
for a given number of points and the device sends points divided by
average (as an example soft asks for 100 but gets 20 if your set avg to x5)

if i remember right some of these things were solved in newer firmware
(dislord ... another help from you needed here ... wink wink)

using average IN THE PC SOFT is a totally different thingy (depending of
pc software very high numbers and super slow scanning could be used)

hope that helps you a bit

greetz sigi dg9bfc


Am 29.06.2021 um 16:14 schrieb Ambro_IW2FVO via groups.io:

Ambro_IW2FVO 2021/06/30 07:13

thanks very much Siegfried and Stan:> I can not find the AVG tab on my device:  "display" (trace, format, scale, channel, AVG!!!!!, transform, flipdisplay, back) : AVG is NOT present.  What is the reason ?> I downloaded the two bin files as per the attached capture: do you suggest me to upload one of these files to my device ? could you please indicate briefly the step by step procedure to load them into the device?  I am sorry to do not be so skilled on this matter  and I do not want to make my vna unserviceable !Yours is a very great help for me .Bye On Wednesday, June 30, 2021, 05:03:14 AM GMT+2, Stan Holmes <zs6hal@gmail.com> wrote:

Just sent him the correct version link for V2_2
https://nanorfe.com/downloads/20201013/nanovna-v2-20201013-v2_2.bin

Ambro_IW2FVO 2021/06/30 07:19

I am attaching the correct capture relevant to the missing AVG selection...bye
On Tuesday, June 29, 2021, 10:35:32 PM GMT+2, Siegfried Jackstien <siegfried.jackstien@freenet.de> wrote:


avg in device can be found under "display" (trace, format, scale, channel, AVG!!!!!, transform, flipdisplay, back)

click on avg and set that to none ... then on "back, another time on back ... and you are in the main menue

now select calibrate (fourth from top) and save (second from top) ... and save 0 ...


.... thats it

from your picture i see that you have still very old (outdated) firmware on your device ... so thats another thing to solve (update your firmware!)

here latest "official" from owo (se added file)


dislord also wrote SEVERAL fw for the different devices (v2 small and big lcd, v2plus with small and big display and for v2plus4 ... with and without fpu) so i do not exactly know what is the last version from displord

i think it was "V2 320x240 noecal 301 points smooth.bin" ... but i am not sure (hey dislord ... lend ambro a hand!! what was your last version for the "normal" v2?!?!?)

some pc software have problems if you have not set avg to 0 ... soft ask for a given number of points and the device sends points divided by average (as an example soft asks for 100 but gets 20 if your set avg to x5)

if i remember right some of these things were solved in newer firmware (dislord ... another help from you needed here ... wink wink)

using average IN THE PC SOFT is a totally different thingy (depending of pc software very high numbers and super slow scanning could be used)

hope that helps you a bit


greetz sigi dg9bfc




Am 29.06.2021 um 16:14 schrieb Ambro_IW2FVO via groups.io:


Thanks a lot Siegfried, I am just a little in trouble trying to solve my problem > in the attached photo you will see the information about my nanovna. > as far as the Avg is concerned: are you talking about the nanosaver or about the nanovna devices ? >I can not find any  AVG setting tab  on my vna device > I can find out the avg setting on the saver program only
>>> could you please indicate to me the step by step procedure please ?     Is my nanovna firmware up to date ?
Thans again for the jelp. bye
On Tuesday, June 29, 2021, 02:28:50 PM GMT+2, Siegfried Jackstien <siegfried.jackstien@freenet.de> wrote:


you have set avg to none ok ...but... then you have to switch to calibrate and save that in slot 0 (no need to do a full calibration just the need to save the settings so the device knows that you want to use avg=0)


there are a few memory slots for storing calibrations but slot 0 is used as default when switching on so that is also used when you connect to usb

if you did not save the settings then it is not used when switching on (or restarting like it does when connect to usb)

save the setings and it should work


greetz sigi dg9bfc

ps what fw version is on your device?!?

Am 29.06.2021 um 14:18 schrieb Ambro_IW2FVO via groups.io:


still NOT able to operate nanovna v2-2  with nanosaver ... Any additional help please ? Thanks. Bye
On Monday, June 28, 2021, 10:18:01 AM GMT+2, Ambro_IW2FVO via groups.io <iw2fvo=yahoo.com@groups.io> wrote:

thanks, I set avg to zero but still have the same problem. Could you please clarify what do you mean with " save to slot 0" ? I do not find any tabs for that. Bye
On Monday, June 28, 2021, 05:51:43 AM GMT+2, Siegfried Jackstien <siegfried.jackstien@freenet.de> wrote:


set avg to none and save in slot 0

program ask for say 100 points and you set device to avg x2 the soft only gets 50 points

avg to none solves that

dg9bfc sigi

Am 27.06.2021 um 22:18 schrieb Ambro_IW2FVO via groups.io:


good day to all in this forum,
I am trying to use Nanosaver 0.3.8 together with NanoVNA V2-2 connected to my PC.. My PC runs windows_10_64 bits, has an Inter I_5 CPU and 8 GRAM.
I was able to connect and use the program just few times but now the program locks up as soos as the USB connect tab is pressed.
The program shows the correct USB port number and it agrees with the device manager. Is there a particule procedure  for connecting the USB ? The program shows " division by zero " somewhere.
I am attaching some screen captures to this mail.
Thanks in advance for any help.
regards
Bye

Vladimir Lebedev 2021/06/30 00:30

Hello Ambro!
Here is manual for the device NanoVNA V2 = SAA-2
https://nanorfe.com/nanovna-v2-user-manual.html
please go to NanoVNA-QT ---> Firmware update

This program and driver you can download here
https://nanorfe.com/nanovna-v2-software.html

This driver is very-very important!!!

73 de Vladimir, dl7pga

Vladimir Lebedev 2021/06/30 00:39

Hello Ambro!
Your FW Version from 01.05.2020 has no AVG point under DISPLAY menue, but FW from 13.10.2020 and 24.11.2020-experimental have AVG (see manual menue map). Experimental version is better.
Vladimir
AVG = average

Siegfried Jackstien 2021/06/30 13:52

old firmware :-(

Am 30.06.2021 um 09:19 schrieb Ambro_IW2FVO via groups.io:

To reply to this topic, join https://groups.io/g/NanoVNAV2

View this thread on groups.io