NanoVNA V2 / Forum

Note: this page is a mirror of https://groups.io/g/NanoVNAV2.
Click here to join and see most recent posts.

nanoVNA v2 Plus4 , a kinda bricked ?


John tf 2020/12/14 09:19

I did several searches to find something that could help with this , did not find , so new thread .
Seemed to bricked my nanoVNA , just received a couple weeks ago , and started just exploring / clicking around , there were a number of clicking tabs that I did not recognize , as an example DMESG etc.
After a few days of poking around I bricked the unit / or made mostly non responsive , I can bring up the touch options on the right side and go & click on everything .
But the screen is sweeping faster than normal , has many , or all of the color of sweeps all over the screen , the only effect I can make , is to pause sweep .
I tried pulling the battery & turning on , figuring some type of reset - no change .
I mainly only use a Macbook Pro , with no kind of Windows on it , haven't found any software to use with Mac , so assuming that I can not reload / updater firmware 20201013 ?
Next issue , have a old Toughbook CF-19 with Windows 7 Pro , last used a few yrs. ago , and I can not get it to recognize my hotspot , things are piling up ;(

--

KD0CAC

John tf 2020/12/14 14:31

Forgot to include screen pictures ,

KD0CAC

Alexander Kalashniko 2020/12/15 01:43

Hello.



Go to calibration, select reset and save to slot 0.





**От:** john.faughn@gmail.com

**Отправл.:** 15 декабря 2020 г. 00:31

**Кому:** NanoVNAV2@groups.io

**Кому:** NanoVNAV2@groups.io

**Тема:** Re: [nanovnav2] nanoVNA v2 Plus4 , a kinda bricked ?

---


Forgot to include screen pictures ,


KD0CAC

_._,_._,_

* * *

John tf 2020/12/14 20:25

--
Dang , that was too easy .

Thanks

KD0CAC

John tf 2020/12/15 09:00

Well under a couple conditions the wild screen keeps coming back , near the end of calibration , it jumps out of the process [ does not allow to complete / load any calibration ] .
Then if I click on any of the unloaded cal. choices / loading points .
And does not respond to plugging in 50 Ohm load / does not put marker on center of Smith Chart ?

KD0CAC

John tf 2020/12/26 19:19

Still having wild screen , cannot do anything , only partially does any function ?
Found a couple of other threads with similar issues , cannot post replies or questions ?

KD0CAC

OwO 2020/12/27 11:30

You might be trying to post to the wrong forum, the other group is
unofficial and they may not approve some messages.

Anyway you need to post some photos of the screen UNCALIBRATED,
measuring each of the OPEN, SHORT, and LOAD standards. A bad calibration
(for example dirt on a cal standard) will cause a random screen.

John tf 2020/12/26 19:33

Many things wrong , tap on screen , menu come up , tap on screen - menu goes away [ on highlight / darking - indicating tap accepted ] .
Totally useless .

KD0CAC

barnc4br 2020/12/26 20:34

it isn't bricked. it is just confused or maybe it is the developer that is confused. There are a lot of mysteries that will be reveled in my manual if I ever get it finished. I find lots of errors in documentation and I am NOT just a newbie with this. Also there isn't anything specific for the v2.4. Maybe it will be ready for comment in a week or two. Actually, I think I will upload the basic part since that is what is not out there and it is close. It may be without some info since I have no found it yet.
Anyway, the answer to your problem is to go to calibrate and *uncheck* APPLY.
I have no idea what that is for yet, but when you do a calibrate it gets set and that is what is messing your screen up.
The other picture appears to be an unsaved memory location. I don't think there is any useful info there.
It worked for me, let me know your results.

barnc4br 2020/12/26 20:36

OwO - unchecking APPLY fixed mine. What is that for? It gets set with every cal.

OwO 2020/12/27 14:54

You have two separate issues, one is you need to do TOUCH CAL, the other
is you have a bad calibration active. Please do the TOUCH CAL and then
post photos of measurements of the 3 cal standards in UNCALIBRATED state
(CAL > RESET ALL).

OwO 2020/12/27 14:56

CAL > APPLY being checked means the calibration is active. If you
uncheck it you are disabling the calibration and so you're in an
uncalibrated state. If checking APPLY gives you random traces, it means
the calibration is bad and you need to click RESET and redo the calibration.

barnc4br 2020/12/29 05:47

Did you get it solved? If not, I have my solution posted elsewhere, but for grins, I was doing it on the wrong port and therefore the calibration was totally messed up. Check out my manual in the files section.

OwO 2020/12/29 22:40

barnc4br: I've uploaded a pdf of your user manual at
https://nanorfe.com/images/V2Plus4_Manual_NC4BR.pdf if you don't object.

On 29/12/2020 21:47, barnc4br@gmail.com wrote:

barnc4br 2020/12/29 08:06

no problem
I did a quick save as with WORD on this and did not review it. When I get some feedback, my next attempt will be to format the docx so that the pdf comes out looking a little cleaner.

barnc4br 2020/12/29 08:06

[Edited Message Follows]

no problem
I did a quick save as with WORD on this and did not review it. When I get some feedback, my next attempt will be to format the docx so that the pdf comes out looking a little cleaner.

On 2nd thought did you reformat it?
I guess I need to turn off tracking b4 I save as huh?
Oh well, the idea is there.

barnc4br 2020/12/29 08:06

[Edited Message Follows]

no problem
I did a quick save as with WORD on this and did not review it. When I get some feedback, my next attempt will be to format the docx so that the pdf comes out looking a little cleaner.

On 2nd thought did you reformat it?
I guess I need to turn off tracking b4 I save as huh?
Oh well, the idea is there.

I am still confused as to the REAL V2 group. I can't upload anything here but I can in the
-V2 group, but I thought THIS was the real group.
Can you straighten me out?

Siegfried Jackstien 2020/12/29 17:02

here some screenshots from plus 4 and from v2plus (modded saa2n)

both with a 511pt fw from discord ;-)

plus4 calibrated with cable the plus without (connected sol direct on
device)

screenshots taken with nanovna_app

greetz sigi dg9bfc


Am 27.12.2020 um 03:30 schrieb OwO:

Siegfried Jackstien 2020/12/29 17:11

there is nanovnav2 and NanoVNA-V2 ... and as a third one nanovna-beta-test

in the third one dislord made a few fw tests ... and now we have 511pt
available :-) in v2, v2plus and in plus4

in the v2 and v2plus only usable with a bigger (4 inch) lcd

greetz sigi dg9bfc

Am 29.12.2020 um 16:06 schrieb barnc4br@gmail.com:

OwO 2020/12/30 02:04

I didn't realize file uploads aren't enabled by default, it should be
enabled now. Thanks for the tip.

barnc4br 2020/12/29 11:11

OK, thanks.
I uploaded my files here also since this is the Official site

John tf 2020/12/29 13:45

Turn on , there is a quick flash of screen with 2 traces , then jumps to all traces random scanning .
Then go to touch screen cal , config , touch cal [ menu goes off ] , also touch test - touch cal highlights and menu goes away .

Next try recall , menu shows # 0-6 - touch # 0 and menu goes away , try again and touch #1 - #0 highlights and screen goes away .

Then touch config and DFU has arrow in front , touch DFU - touch DFU and get emnu reset and enter DFU  , and cancel below , touch cancel and sometimes menu goes away , other times screen goes blank with text saying DFU update mode to exit DFU reset yourself .

So there is a issue with touch replying many / most of the time with second option - highlighting the first menu option .
Can not cal touch screen .

Most other functions can not work with touch screen causing these issues .

KD0CAC

OwO 2020/12/30 11:39

1. Use the buttons to navigate the menu, go into CONFIG > TOUCH CAL, and
perform the touch calibration.

2. CONFIG > SAVE.

3. CAL > RESET ALL, then CAL > SAVE and save into slot 0.

4. Do not calibrate, measure each of the 3 cal standards and post
screenshots.

John tf 2020/12/30 11:16

OK did as you mention , your #3 is not clear - " then CAL > SAVE " no mention of having to back page the menu to get to save ?

The pictures after above seem to show the through , but then use the O L S , no change of screen .

Also , after doing manual config touch , the top menu selection still clears menu from screen ?

KD0CAC

OwO 2020/12/31 13:56

Yes, CALIBRATE > SAVE.

After doing TOUCH CAL, try TOUCH TEST and draw on the screen. If the
position is off you still have a bad touch calibration. If it's erratic
the touchscreen is defective.

It looks like the ports are floating, can you try connecting the 50ohm
load standard directly to port 1 (as in attached photo) without a cable?

John tf 2020/12/31 08:06

Yes I've done all of he above , drawing will sometimes have very small breaks / gaps in the line .

Any standard added to port 1 , either with or without shows no reaction / change on screen .

KD0CAC

John tf 2021/01/08 08:13

Still have the multiple issues , when menu is up about 90%+ of the time touching the top menu option does not work - when touching the top menu option the menu goes away .
I have done the touch & cal , many times .

Then after doing calibration , also many times , the only change in what the screen shows - seems to be the through - connecting the 2 coax's together - the 1st of the 4 pictures above , any other standard - no change is traces or text on screen ?

Hopefully I / we can figure something out , instead of returning ?

KD0CAC

OwO 2021/01/09 00:58

Did you do the touch cal with the pen and make sure you touch the very
topleft and bottomright corner? And is port 1 completely nonresponsive?
touch a needle to the center of the SMA connector on port 1 and see if
the smith chart changes?

John tf 2021/01/09 11:38

Yes as mentioned above several times - I did Touch Test & Touch Cal many times and saved .
Still top menu option almost always is non-responsive --- except for clearing the menu from screen .

Yes port 1 is completely unresponsive - lightly touch center connector with needle and the change in any text on screen is the same range of change of all posted in screen text's if left sitting without touching center connector of port 1 .
CH0 LOGMAG 10dB/0.00dB
CH0 SMITH 1.0 FS [ this varies with sweep ] -87 to about -250 - 6.44 to 6.70kj

the other side of screen
SH1SMITH 9.0FS [ next varies little ] 49.9 to 5050.8 then varies a lot 1.23mj  -375uj
CH1 PHASE90*/. -0.87
1:6.084 000 MHz

markers & traces never vary .

Thanks again
KD0CAC

To reply to this topic, join https://groups.io/g/NanoVNAV2

View this thread on groups.io