Beware of cheap underperforming clones

As of 2022 there are many badly performing clones on the market. V2/3GHz NanoVNA uses parts like ADF4350 and AD8342 which are costly and clones have been cutting costs by using salvaged or reject parts.

See official store and look for V2 Plus4/V2 Plus4 Pro versions only to avoid getting a bad clone. We have stopped selling V2.2 versions since October 2020, so all V2 hardware that are not Plus or Plus4 are not made by us and we can not guarantee performance.

NanoVNA V2 Forum

Note: this page is a mirror of
Click here to join and see most recent posts.

White screen NanoVNA v2.2

klaasjandunnink 2020/12/14 11:49

Hello all, I received my NanoVNA v2.2 a couple of weeks ago. At first it worked like a charm, but after a while I sometimes had a white screen at bootup, and sometimes the VNA became stuck while operating it via the touch screen. At first I thought of a broken screen, so I ordered a new one. Its however no solution, because with the new screen fitted the behavior is the same. I can connect to the unit via USB and run an upgrade if I boot it in DFU mode, so that's all fine.

Based on the schematics I checked the connection between MCU (U303) and the display, and this is good to, so no soldering issue. It is strange the issue has popped up, cause at first usage there was no such issue. The unit has not been dropped or misused.. Any suggestions on what to check or what could be the problem?

Thanks in advance!

klaasjandunnink 2020/12/14 11:57

Hello all,

I am having issues with my NanoVNA v2.2. I am having a white screen at boot. I have been using the unit for some weeks before the issue occurred that the NanoVNA incidently got stuck during operation via the touch screen, or that it would boot with a white screen. The unit is reachable via USB and firmware can be written. I have tried both the october and september release, no luck. I have replaced the display but it makes no difference. Have checked the connections from the MCU to the display, they match the schematic.

Any suggestions?

Thanks in advance.

Siegfried Jackstien 2020/12/15 16:32

are you sure that you did not accidently flashed the wrong firmware??

dg9bfc sigi

Am 14.12.2020 um 19:57 schrieb

klaasjandunnink 2020/12/15 09:40

The board has 'v2.2' on the silkscreen. So I flashed it with the firmware adhering to the v2.2.

Siegfried Jackstien 2020/12/15 17:52

what screensize?? 2.8 to 3.5 inch?? or a 4 inch??

i still guess you just used the wrong fw ...

what app did you use to upload fw?? (i ask cause there are now TWO app
that can burn a new fw inside)

did you try a power cycle after fw upload??

we sure can solve that ;-)

greetz sigi dg9bfc

Am 15.12.2020 um 17:40 schrieb

klaasjandunnink 2020/12/15 12:36

Off course, you ask valid questions.
My model is 2.8 inch. I used the NanoVNA-QT software for Windows. Firmware is ending on v2_2.bin.
Yes, I did a power cycle after the firmware was uploaded.

Thanks so far for your input!

jacobuscrucq 2022/10/17 14:07

I have the same problem. Did you find a solution ??

To reply to this topic, join

View this thread on