Beware of cheap underperforming clones

As of 2022 there are many badly performing clones on the market. V2/3GHz NanoVNA uses parts like ADF4350 and AD8342 which are costly and clones have been cutting costs by using salvaged or reject parts.

See official store and look for V2 Plus4/V2 Plus4 Pro versions only to avoid getting a bad clone. We have stopped selling V2.2 versions since October 2020, so all V2 hardware that are not Plus or Plus4 are not made by us and we can not guarantee performance.

NanoVNA V2 Forum

Note: this page is a mirror of
Click here to join and see most recent posts.

WIN 10 Issue

Ted Chesley 2020/10/09 19:26

Hi everyone. Anybody run into a problem with windows 10 connecting to
SAA-2N (20200926 FW) after installing the latest Windows feature
update ver 2004? This update just came through this morning and I ran
it. Now the SAA-2N shows up in Device Manager as "System
Devices-Universal Serial Bus Controllers-USB to UARP Adapter" with the
Cypress driver, but it does not assign a COM Port as it previously did
before the update, when all operation was normal.. NanoVNA-QT will, of
course, not connect. Tried it on my WIN 7 machine and all is normal.
Tried my H4 on the Win 10 machine and it assigned a COM port as normal
with the MS Driver.
Maybe a driver issue? Any suggestions?
THX....Ted (KD7AQO)

Juan Manuel Muñoz 2020/10/09 23:30

Hello, I had that problem a few days ago and not even reinstalling the
driver was solved.
What I did to solve it was to replace the driver already installed by
the ZADIC libusb (in CDC mode). With this everything worked again.


El vie., 9 oct. 2020 a las 21:26, Ted Chesley (<>)

John Clark 2020/10/09 15:50

Yes. I cleared this exact problem last week for my V2. My windows built
a new "Unknown Device" in the Device Manager list.

I did a refresh the driver in this device and it gave me a good COM-6
with the Cypress driver installed.

I hope this helps.




On 10/9/2020 1:26 PM, Ted Chesley wrote:

Ted Chesley 2020/10/09 16:07

THX Juan and John for the quick replies. I'll give it a try and see what happens.

Worked fine this morning, then I updated win 10 and the problem shows up. Typical windows I guess.

Ted Chesley 2020/10/09 23:14

Had two "unknown devices" in Device Mgr. First one, I tried to update
the driver with no luck, but on the second one, update driver worked,
unknown device cleared, and when connecting the SAA-2N, picked up COM
8. Everything now works OK.
Many THX.

To reply to this topic, join