NanoVNA V2 / Forum

Note: this page is a mirror of https://groups.io/g/NanoVNAV2.
Click here to join and see most recent posts.

V2 Plus Firmware


Joe Smith 2021/07/25 14:08

I purchased both the V2 Plus and the Plus 4 when they were released.  Both came from their official store.  Both had firmware the predates the stable release.   The Plus 4 has been very stable but the Plus will hang, requiring a power cycle to recover.  I ended up setting it aside after not being able to solve the problem.  It's been a while so today I thought I would see if the newer firmware would solve the problem.  After uploading the experimental firmware, the screen stays white.  A power cycle, the screen remains white but the unit connects.  It is not in the programming mode.  Installing the latest stable release, it returns to normal.  I let it run and after about seven hours it again hung.  This is typical for what I had been seeing with this particular VNA.

Are the other binary images archived?  I would like to know if the last version that at least allows the screen to come up would have this same lockup problem.

IW2FDH 2021/07/25 14:25

Joe,

V2 has a lot of problems, caused mainly by 1) bad flux not sufficiently removed (all pcb)    2) bad soldering (mainly Mcu). I've got strange random hangs (plus other problems), solved by a lot  IPA and related soldering

Best regards

Andrea   (Milan - Italy)

Joe Smith 2021/07/26 03:44

While the title and first post mention the V2 Plus,  it may not have been clear that it's not the V2.2 shown here:
https://nanorfe.com/nanovna-versions.html

I had tried a fair number of tests before tossing the V2 Plus aside which of course included a thorough inspection of the main PCB.  If you would like to read more about it:
https://www.eevblog.com/forum/rf-microwave/nanovna-custom-software/msg3344620/#msg3344620

I attempted to download the latest experimental firmware a second time and reinstall it but was met with the same white screen effect.   Normally I would expect firmware to be vetted prior to release but when it comes to these low cost VNAs, finding stable firmware has been rare.  While I was not able to locate an archive for the binaries, someone had posted a link to a version they claimed was for the V2Plus that was between the latest experimental and the stable release.  Once installed, the screen appeared formatted for the larger screen.  Maybe it was for the V2Plus4.  That firmware has now been running for 15 hours with no lockup.   That's more than 2X longer than the unit has ever ran for without locking up.   I plan to let it continue running for the day but I am confident now that I am once again dealing with a firmware problem.

Joe Smith 2021/07/26 19:52

Oddly enough in a thread talking about lock up problems, there's another version which appears to run on the V2 Plus with the screen formatted correctly.

https://nanorfe.com/forum/Nanosaver-lock_up.html

I don't yet have near the run time on this version as I did the previous but it is once again well beyond where I would normally see the V2 Plus lockup.   I am not looking yet at if there are other problems with the firmware, just that it stays connected while collecting data without locking up.   Because I don't use these VNAs standalone, it's possible any known problems may not even effect me.

I had thought about getting a second V2 Plus just to see if I could replicate the problem on another unit but it's clear now I was once again dealing with a firmware problem.

DiSlord 2021/07/26 20:52

I try test your soft on my V2Plus device.

PS you can try my fw variant (320x240 for 2.8 screen, 480x320 for 4 inch screen), but if you made calibration in CPU soft, need disable calibration on device (my fw send calibrated data to CPU if enabled), also selected avg setting apply to this data (big avg setting - slow measure, need more wait, but get more clean result).

PSS As a guess, there may be a buffer overflow from a large number of commands, but this is not certain.

Joe Smith 2021/07/27 04:37

That version of firmware has now ran for 24 hours non-stop without a single lockup.   Next step is to see if it will put out some decent data.

DiSlord, most likely if this version works well enough to allow me to use the V2Plus, I won't spend any more time looking at firmware for it.  I've not had any problems with the firmware supplied with my V2Plus4 and would have no reason to change it.

OwO 2021/07/27 05:32

I released a new firmware 20210726 with some bugfixes: https://nanorfe.com/downloads/20210726/nanovna-v2-20210726-v2plus.bin
Can you see if the lockup is fixed?

n2msqrp 2021/07/27 09:43

Will this woek on the v2plus4 version?



Thanks in advance.



Mike N2MS

> On 07/27/2021 8:32 AM OwO <owowowowo123@outlook.com> wrote:

>

>
>

>
>

> I released a new firmware 20210726 with some bugfixes:
<https://nanorfe.com/downloads/20210726/nanovna-v2-20210726-v2plus.bin>
> Can you see if the lockup is fixed?

_._,_._,_

* * *

OwO 2021/07/27 08:45

Latest firmware
V2 plus4 - https://nanorfe.com/downloads/20210726/nanovna-v2-20210726-v2plus4.bin
V2 plus - https://nanorfe.com/downloads/20210726/nanovna-v2-20210726-v2plus.bin

Joe Smith 2021/07/27 11:22

On Tue, Jul 27, 2021 at 08:32 PM, OwO wrote:

>
> I released a new firmware 20210726 with some bugfixes: https://nanorfe.com/downloads/20210726/nanovna-v2-20210726-v2plus.bin
>
> Can you see if the lockup is fixed?

What changes have been made versus the version I am looking at?   I wonder if if offers any advantage?

One thing I am very interested in is getting the programmable gain to work.  I looked at your documentation and there is still no mention of it.   I tried this newer firmware with your original software and it still doesn't appear to work.   That would be a useful feature to have.

Looking forward to hearing more about your V3.  Hope you are planning to move forward with it.

Joe Smith 2021/07/27 17:14

I tried to load your most recent version just to see if it would even boot up, which I am happy to say it did.    Sadly, after about a half hour of testing, it locked up.  Again, requiring a power cycle to recover.

John Zhong 2021/07/28 06:32

The new 20210726 firmware fixes my NanoVNA Saver issue.

On Tue, Jul 27, 2021 at 6:14 PM Joe Smith via groups.io <joeqsmith49=
yahoo.com@groups.io> wrote:

alepplew 2021/08/28 09:15

For a medical Radar application I would need to know the sampling rate of the V2+4. It looks like it is 200 Hz in CW mode with USB Fifo transfer, but I didn't find it specified. Is the sampling rate fixed? Is it a function of sweep range, numbers of points per sweep? How does it behave in CW mode?
Thanks in advance

Dirk 2021/08/29 11:31

NanoVNA had a measuring freq. of 100 Hz, upgraded from HW version 2.3 on to 200 Hz.

alepplew 2021/08/30 08:41

I measured the sampling rate of the NanoV2+4 using a CW 2.4 GHz at 101pts per "sweep" and feeding the reflected wave into port2. A pendulum reflector was filmed and the mechanical movement period determined from the video.
The measured sampling rate of the V2+4 is 400 Hz.

To reply to this topic, join https://groups.io/g/NanoVNAV2

View this thread on groups.io