NanoVNA V2 Forum

Note: this page is a mirror of https://groups.io/g/NanoVNAV2.
Click here to join and see most recent posts.

Unknown USB Device(Device descriptor request failed)


cyberalan71 2020/07/24 05:07

Hello

I tried to use V2 with PC, but i cant install drivers.
Device hardware id is incorrect: VID_0000&PID_0002
Driver is not installed.
How to solve this?
Maybe i bought a clone device?

CT2FZI 2020/07/24 06:27

Hello

Did you read user manual? Did you check the home page for software?

Try:

https://github.com/nanovna/NanoVNA-QT/releases

On Windows, please run CypressDriverInstaller_1.exe to install the USB-CDC driver.

cyberalan71 2020/07/24 13:43

Hello
of course i did it. I tried to manual update driver after. Nothing. I suppose the device does not have correct device id and windows cant recognize wich driver should be used.

cyberalan71 2020/07/24 13:49

Also i tried manual install driver by Zadig. Zadig reports error that device with this id has already used. Please see the screen usb ID section. I think the problem is the device flashed icorrectly with no hardware ID.

cyberalan71 2020/07/24 13:53

screen

CT2FZI 2020/07/24 22:36

Try in another pc, clear device from registry, uninstall old drivers.

A sexta, 24/07/2020, 21:49, <cyberalan71@gmail.com> escreveu:

cyberalan71 2020/07/27 04:43

I did it, the result is the same

cyberalan71 2020/07/30 02:58

Is there other interface, to reflash the device? Non usb, for example SPI or ISP?

cyberalan71 2020/07/30 03:45

Or is there a way to change VID/PID?

MarkZ 2020/07/30 03:57

If you look at the photos on this page: https://groups.io/g/NanoVNAV2/topic/v2_photos/74581398?p=,,,20,0,0,0::recentpostdate%2Fsticky,,,20,2,60,74581398

the first photo shows a debug port on the edge of the card. A standard jlink debugger will connect to this (as will others). The debugger can easily reprogram the bootstrapper. You can search on amazon for jlink debugger and find a bunch.

Mark

cyberalan71 2020/07/30 04:14

Does this help me?
https://aliexpress.ru/item/32743219240.html?spm=a2g0o.productlist.0.0.318116e3kBKwAH&algo_pvid=d5c5cc55-8e2c-4c8c-835d-ba7bdd8301c3&algo_expid=d5c5cc55-8e2c-4c8c-835d-ba7bdd8301c3-7&btsid=0b8b036d15961072933711088e35c9&ws_ab_test=searchweb0_0,searchweb201602_,searchweb201603_

MarkZ 2020/07/30 04:42

Yes, exactly that kind of thing. I can't guarantee you can find software for it since I don't know how compatible, but the debug port is very simple. The cheapest such devices on Amazon are about $12.

Mark

cyberalan71 2020/07/30 05:08

Thanks
Also
Is there way to force win10 to work with my device that have such VID_0000&PID_0002?

cyberalan71 2020/07/30 07:48

I found the problem!
There was short circuit between d+ and d-.
I resoldered usb socket and problem has gone.
Thanks for all.

To reply to this topic, join https://groups.io/g/NanoVNAV2