NanoVNA V2 / Forum

Note: this page is a mirror of https://groups.io/g/NanoVNAV2.
Click here to join and see most recent posts.

Unknown USB Device (device Descriptor Request Failed)


Mike, AA9VI 2021/06/29 09:54

I am using Win10.  Has anyone had any trouble connecting a NanoVNA2 v4 to a PC?  I get the following USB error under Device Manager if I connect the NanoVNA before starting the QT software:
Unknown USB Device (Device Descriptor Request Failed)

When I click on that description it says:
Windows has stopped this device because it has reported problems. (Code 43)

A request for the USB device descriptor failed.

I tried multiple computers and see the same error.  I even tried to manually install the Cypress driver as Serial USB device since Windows was finding some Microsoft driver initially. Then, I get rid of the USB error and the QT software sees the COM port.  I select the COM port but the QT  gives me this error:

xavna_read_autosweep failed:  Resource deadlock avoided

Nothing seems to work.  The VNA has an operational screen with the traces and menus.  I cannot use the windows software anymore due to a USB error.  Any suggestions?   Do I need to JTAG or whatever with the STM?  Where is that process and the pin locations documented?   Can anyone confirm the Cypress driver hardware type:  Serial USB?

Thanks,
Mike

zeljko adzic 2021/06/30 09:35

https://drive.google.com/file/d/1Ov6BbQd2-nMFFicU9IQicklIJpjNDWQX/view



On Tue, 29 Jun 2021, 19:05 Mike, AA9VI via groups.io, <mjswiatk=
yahoo.com@groups.io> wrote:

Mike, AA9VI 2021/07/17 17:43

that doesn't seem to work.  Does anyone have any other ideas?

yvan.blom 2021/07/17 23:23

Hi Mike,

I remember I had a similar problem, both on windows and Linux. Swapping the 2 USB data lines did the trick.
Does this help?
Yvan, ON4YVM

Vladimir Lebedev 2021/07/18 00:54

Hello Mike!
Have You driver for V2 devices installed?
https://nanorfe.com/downloads/NanoVNA-QT/CypressDriverInstaller_1.exe
73 de Vladimir, dl7pga

To reply to this topic, join https://groups.io/g/NanoVNAV2

View this thread on groups.io