NanoVNA V2 Forum

Note: this page is a mirror of https://groups.io/g/NanoVNAV2.
Click here to join and see most recent posts.

Struggling to get NanoVNAsaver working on Mac #nanovna-saver


Tony Abbey 2020/08/04 07:47

I'm following the guide here:

https://github.com/NanoVNA-Saver/nanovna-saver

to get the software running under MacPorts on my MacBook Air running MacOS Mojave 10.14.6. All apparently installed OK, but I get the following errors when I try and run the app.
It's all a bit outside my knowledge, I'm afraid - I have tried re-installing, but makes no difference:

Macs-Air:MacPorts Tony$ NanoVNASaver
Traceback (most recent call last):
File "/opt/local/bin/NanoVNASaver", line 10, in <module>
from importlib.metadata import distribution
ModuleNotFoundError: No module named 'importlib.metadata'

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File "/opt/local/bin/NanoVNASaver", line 13, in <module>
from importlib_metadata import distribution
ModuleNotFoundError: No module named 'importlib_metadata'

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File "/opt/local/Library/Frameworks/Python.framework/Versions/3.7/lib/python3.7/site-packages/pkg_resources/__init__.py", line 583, in _build_master
ws.require(__requires__)
File "/opt/local/Library/Frameworks/Python.framework/Versions/3.7/lib/python3.7/site-packages/pkg_resources/__init__.py", line 900, in require
needed = self.resolve(parse_requirements(requirements))
File "/opt/local/Library/Frameworks/Python.framework/Versions/3.7/lib/python3.7/site-packages/pkg_resources/__init__.py", line 791, in resolve
raise VersionConflict(dist, req).with_context(dependent_req)
pkg_resources.ContextualVersionConflict: (scipy 1.5.2 (/opt/local/Library/Frameworks/Python.framework/Versions/3.7/lib/python3.7/site-packages), Requirement.parse('scipy<1.5'), {'NanoVNASaver'})

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File "/opt/local/bin/NanoVNASaver", line 15, in <module>
from pkg_resources import load_entry_point
File "/opt/local/Library/Frameworks/Python.framework/Versions/3.7/lib/python3.7/site-packages/pkg_resources/__init__.py", line 3260, in <module>
@_call_aside
File "/opt/local/Library/Frameworks/Python.framework/Versions/3.7/lib/python3.7/site-packages/pkg_resources/__init__.py", line 3244, in _call_aside
f(*args, **kwargs)
File "/opt/local/Library/Frameworks/Python.framework/Versions/3.7/lib/python3.7/site-packages/pkg_resources/__init__.py", line 3273, in _initialize_master_working_set
working_set = WorkingSet._build_master()
File "/opt/local/Library/Frameworks/Python.framework/Versions/3.7/lib/python3.7/site-packages/pkg_resources/__init__.py", line 585, in _build_master
return cls._build_from_requirements(__requires__)
File "/opt/local/Library/Frameworks/Python.framework/Versions/3.7/lib/python3.7/site-packages/pkg_resources/__init__.py", line 598, in _build_from_requirements
dists = ws.resolve(reqs, Environment())
File "/opt/local/Library/Frameworks/Python.framework/Versions/3.7/lib/python3.7/site-packages/pkg_resources/__init__.py", line 786, in resolve
raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'scipy<1.5' distribution was not found and is required by NanoVNASaver

Tony

Tony Abbey 2020/08/04 07:56

Replying to my own post, I found the already packaged version for the Mac here, and that works fine.
https://github.com/nanovna/NanoVNA-QT/releases
Sorry to have bothered you all.

Tony

helmar 2020/08/04 23:26

there are detailed instruction on github
did you use port or homebrew

in any case its probably more likely to get answers on github by the nanovansaver group
https://github.com/NanoVNA-Saver/nanovna-saver/issues

Tony Abbey 2020/08/05 07:57

Hi Helmar

I was using Macports. I'll try posting the same error messages on GitHub, but the issues they talk about tend to be programming features, not installation problems.
I did also try home-brew, and it took an awful long time to install. It worked once using the command line 'python3 -m pip install' and 'NanoVNASaver' Now I get the same error messages.
As I said, I found the simpler precompiled version via_qt which works OK.
Tony

MarkZ 2020/08/05 11:52

Hi,

There's a very large difference between nanovna-saver and vna-qt. My opinion is that saver is much much more useful and other than occasional instability it's a much nicer product to use. Most of what you've described is missing libraries and I noticed you type "python3 -m pip install" but the actual line should be "python3 -m pip install ." with a trailing period (.) that's important (yay linux).

I just went through an installation on a totally new mac and it worked like a champ but with slight differences. I wrote them up and maybe you could give it a try. I used Homebrew because it has more steps that are simple to validate. This is using markup language so ignore the html tags. On my rather old mac mini it took maybe 3 or 4 minutes to install.


#### Homebrew

1. Install Homebrew from <https://brew.sh/> (This will ask for your password)

/bin/bash -c "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install.sh)"

2. Python :

brew install python

3. Pip :<br/>
Download the get-pip.py file and run it to install pip

curl https://bootstrap.pypa.io/get-pip.py -o get-pip.py
python3 get-pip.py

4. NanoVNASaver Installation : <br/>
clone the source code to the nanovna-saver folder

git clone https://github.com/NanoVNA-Saver/nanovna-saver
cd nanovna-saver

5. Install local pip packages (don't forget the . at the end)

python3 -m pip install .

6. Run nanovna-saver in the nanovna-saver folder by:

python3 nanovna-saver.py

Regards,
Mark

Tony Abbey 2020/08/05 16:42

Hi Mark

Thank you for your well documented procedure. I performed it all, including reinstalling Brew, slightly worried that I was reinstalling everything I had previously installed, but the scripts seem to take care of that perfectly. BTW - I hadn't missed that pesky "." in "python3 -m pip install ."
Anyway - the upshot is that it installed correctly and I can now run nanovna-saver. Thank you!
There is one problem that doesn't seem to be affecting the operation of the program - the console is showing the following error:
Settings: /Users/Tony/.config/NanoVNASaver/NanoVNASaver.ini
2020-08-06 00:24:19,409 - NanoVNASaver.Windows.About - ERROR - Checking for updates produced a URL exception: <urlopen error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed: unable to get local issuer certificate (_ssl.c:1108)>

Maybe my internet had temporarily gone down which it seems to do a lot nowadays.

Regards
Tony

helmar 2020/08/05 22:35

1) regarding _ssl.c:1108
sounds more like problem with certificate, an something to do with python, not sure how to solve it though. lots of hits in google, you just have to work through if its creates problems
or if its bothering you, otherwise wtf :)

1) regarding pip
next time you install pip on mac better use
$ sudo easy_install pip
$ sudo pip install --upgrade pip

MarkZ 2020/08/06 04:44

Glad to hear it worked for you Tony. The SSL error might be correct since it's whining about a certificate. Mac tends to do security different from Windows and who knows. It could also just be there wasn't a working web connection.

I'll see about updating the readme on github.

-Mark

To reply to this topic, join https://groups.io/g/NanoVNAV2