NanoVNA V2 Forum

Note: this page is a mirror of https://groups.io/g/NanoVNAV2.
Click here to join and see most recent posts.

NonoVNA stop detecting by Win10 PC


Rasika Liyanage 2020/08/04 01:32

Hi team
All of sudden VNA V2 stop detecting in my PC. All this time it worked flawlessly. Tried different usb cables, usb ports no luck.
Has any one else experienced a similar issue and have resovled?

Cheers, Ras

Rasika Liyanage 2020/08/04 01:34

more info, while open the device manager i plugged in the VNA, it is not detecting. can't see under Ports.

CT2FZI 2020/08/04 03:17

Have you tried it in a different PC and/or connect it to an Android phone?

You can also try to start windows in safe mode and try to see the device.

Rasika Liyanage 2020/08/04 04:37

yes I tried on a different pc and it worked.

Rasika Liyanage 2020/08/04 05:15

Started in safe mode, still not showing under COM ports

CT2FZI 2020/08/04 05:19

On Tue, Aug 4, 2020 at 01:15 PM, Rasika Liyanage wrote:

>
> Started in safe mode, still not showing under COM ports
>

Not related with nanoVNA, I had issues with a Windows 10 machine that did not display any COM ports.

Try to follow these steps, it might work: https://social.technet.microsoft.com/Forums/en-US/6c16cd43-0080-47fb-8f71-843fe9f7ffb2/com-ports-missing?forum=win10itprohardware

Kurt Poulsen 2020/08/04 14:34

Hi Rasika
Have you tried a different USB cable. That is quite often the problem
Kind regards
Kurt

Rasika Liyanage 2020/08/04 05:53

followed the steps. added a new porr. how do i get NanoVNA on mapped to that port?

Rasika Liyanage 2020/08/04 05:56

Hi Kurt
yes tried with a few USB cables. Issue seems to be with my PC, when i plugged in to USB port it is not recognizing the VNA. Earlier it did and all of sudden it stopped detecting it. Tried on another PC, can connect with out any issues.

cheers

CT2FZI 2020/08/04 06:00

On Tue, Aug 4, 2020 at 01:53 PM, Rasika Liyanage wrote:

>
> followed the steps. added a new porr. how do i get NanoVNA on mapped to that
> port?
>

It's automatic. It should work. Did you try any other USB device to those ports? Like a USB pen, is it working?

Too many variables, since the nanovna is recognized in another PC, its not related to the nanovna.

Siegfried Jackstien 2020/08/04 13:05

... some smartphone have only a charger cable with 2 wires in it ...
(charge only... no data lines)

if you accidently grab such a cable you can test years and years and
nano will not be found under comports

dg9bfc sigi

Am 04.08.2020 um 12:34 schrieb Kurt Poulsen:

Rasika Liyanage 2020/08/04 06:06

Hi Luis
Agree with you it is not related to VNA. But i'm trying to figure what's going on with my shack PC not to detect the VNA.
When i plugged in any other USB device to one of those ports it detect with out any issues.

Cheers

Rasika Liyanage 2020/08/04 06:10

manually added port

Rasika Liyanage 2020/08/04 22:24

As i mentioned earlier i have tried multiple USB cables. VNA is not detected by Win10 PC A. But when i use the same cable(s) it is detected by Win10 PC B.
For sure the problem is not with the USB cable, but with PC A not detecting the VNA. And again this started all of a sudden on Win10 PC A.

MarkZ 2020/08/05 04:12

Hi,

If it works fine on a different PC with the same cable, then either (1) you have a bad driver on the second pc or (2) the usb port on the second pc isn't working. Both are common. I have a usb hub with two ports dead after some time and pc usb ports often die do to misuse. Similarly, I forgot to install the cypress driver and it didn't work at first for me, either.

The nanovna uses the cypress usb driver. Are you entirely sure you have such a driver? If the driver isn't working, when you plug in the nanovna it won't show up as a serial port. You might try uninstalling/reinstalling the cypress driver.

You can't define a port and then map the nanovna to it. That just won't work.

Regards,
Mark

Rasika Liyanage 2020/08/05 04:46

On Wed, Aug 5, 2020 at 12:12 PM, MarkZ wrote:

>
> cypress driver
>
Hi Mark
You nailed it. Issue was with the cypress driver. It was classed with my Amp's USB serial port. Uninstall the reinstall the cypress driver, and assigned a new port number. Bingo it worked. Thank yo so much for the direction.
Cheers
Ras

To reply to this topic, join https://groups.io/g/NanoVNAV2