NanoVNA V2 / Forum

Note: this page is a mirror of https://groups.io/g/NanoVNAV2.
Click here to join and see most recent posts.

No device under Win10


Roger 2021/03/24 01:35

I connect NanoVNA V2plus4 to the PC (Win10 64 Home) and get "Device COM5" but I do not see any drive.
When I look at Device COM5 in Properties, it says Device COM5 not migrated.
I have also tried with my laptop, same behaviour.
I have also tried five different USB cables, no change.
What should I do?

Roger

UlrichKraft 2021/04/12 07:58

Hello Roger,
I have exact same problem on WIN10 Pro 64bit.
The Cypress driver installed without problems and device is shown in "Device Manager". But that COM port for "NanoVNA V2plus4" is not shown on SaverSW, the "serial  port" window remains blank, "rescan" doesn't find anything, independent of Saver SW versions. (I tried version 0.22 and 0.3.8, both 32bit and 64bit version)).

However when running the alterntive Windows "vna_qt.exe" software everything works well. So it can't be any cable or USB-driver issue.

Did you find ayn solution to that problem ?

Ulrich

OwO 2021/04/12 23:03

Try manually entering the COM port name in nanovna saver like: \\.\COM1

On 12/04/2021 22:58, UlrichKraft wrote:

UlrichKraft 2021/04/12 09:17

OwO,
thanks for the quick reply, but your idea doesn't help.  I also tried on another WIN10 PC, same problem.

CypressDriverInstaller_1:
Driver   Cypress
Date    13.Oct 2015
Version 3.13.0.59

Something strange on both PC:
Device manager / COMport/Driver/ Events...
... Ports\VID_04B4&PID_0008\1&2b53a856&0&00" erfordert weitere Installationen. = *requires addtional installations.* I have no clue what that means ???

But the strange thing is, all works fine with "vna_qt.exe" = VNA View.
I can select \\.\ COM4 and it runs

So I guess the VNASaver SW istn't fully supporting that Cypress chip in the NanoVNA V2plus4 ??

David Eckhardt 2021/04/12 16:36

Welcome to the club. I've pretty much given up trying to connect the V2 to
the PC or laptop under WIN 10 / 64. I have the V2N and am unable to
connect to either Saver or QT with the Cypress driver installed in the same
folder. It is recognized on the USB buss, but that's as far as it goes.
However, it's a spiff instrument as a stand-alone!

Dave - WØLEV

On Mon, Apr 12, 2021 at 4:19 PM UlrichKraft <kraftulrich1@t-online.de>
wrote:

> OwO,
> thanks for the quick reply, but your idea doesn't help. I also tried on
> another WIN10 PC, same problem.
>
> CypressDriverInstaller_1:
> Driver Cypress
> Date 13.Oct 2015
> Version 3.13.0.59
>
> Something strange on both PC:
> *Device manager / COMport/Driver/ Events...*
> ... Ports\VID_04B4&PID_0008\1&2b53a856&0&00" erfordert weitere
> Installationen. = *requires addtional installations. *I have no clue
> what that means ???
>
> But the strange thing is, all works fine with "vna_qt.exe" = VNA View.
> I can select \\.\ COM4 and it runs
>
> So I guess the VNASaver SW istn't fully supporting that Cypress chip in
> the NanoVNA V2plus4 ??
>
>
>

--
*Dave - WØLEV*
*Just Let Darwin Work*

Mike Suhar 2021/04/12 12:38

I managed to get mine to work on both Winders 10 PCs with the saver
software. I have to leave to run a few errands now. When I get back I will
write something up.

Mike


On Mon, Apr 12, 2021, 10:59 UlrichKraft <kraftulrich1@t-online.de> wrote:

Mike Suhar 2021/04/12 11:58

Back home, so here is what I did.  I have two Win10 PCs. Both are running WIN 10 Pro. One is a laptop and the other a desktop.

Looking at the laptop first.

Laptop WIN 10 Details:

Version 20H2, build 19042.906. Latest updates:

KB5000842 Update for Windows Package ( I think this was an optional update, and the last one installed. I installed this one before doing what is described below)

10.0.19041.903 Servicing Stack 10.0

KB4601050 Update for Windows

KB4562830 Feature Update for Windows 10 20H2 via Enablement

After KB5000842 is installed reboot the PC and see if that fixes the problem. In my case it did not.  I have not idea if you need this update.  If you don't have it go without it.

When the NANO connects to the PC two items should appear in “Device Manager”. Under “Universal Serial Bus controllers” will be “USB to UART Adapter”. The second under “Ports (COM & LPT)” will be “USB Serial Port (COMx). COM3 in my case. On the laptop, if I recall, I never got the COM port. On the other PC I got a COM port, but the Saver software did not see it. In both cases if you look at driver property it should say “cypress”.

I noticed something else in Device Manager. There was an “Other Devices” listed. It had a little yellow triangle in the icon. In that section was “Virtual Serial Port Device 00”. Right click and select “update driver. You are shown a couple of options as to where to find the driver. Both failed but I was given a third option to look to Windows Update. Found a driver and it installed. I viewed “optional updates” and found a Cypress. Installed that driver and “Other Devices” disappeared. I now had a COM port. I think I did a reboot here also. Connected the NANO. COM port was there. Started the Saver Software. It took awhile to load. It started and it found a COM port. I clicked “connect” and I was good to go. For the laptop that is all it took. For the Desktop, not so lucky.

The desktop:

Installed updates:

KB4601554 Update for Windows

KB5000842 Update for Windows (optional update I installed before starting this)

10.0.19041.903 Servicing Stack 10.0

KB4562830 Feature Update for Windows 10 20H2 via Enablement

KB4589212 Update for Windows

KB4586864 Security update for Windows

KB4570334 Security update for Windows

KB2504637 Unspecified

Installed KB5000842 as above. Rebooted, no luck. Also, I did not have the “Other Devices” in “Device Manager”. I had the “USB to UART Adapter” device so I right clicked and selected update driver. It came back that I had the latest driver. I selected “uninstall” and took it out. If a COM port showed up when the NANO was connected under “Ports”, right click and uninstall that one also. It will be the one with the Cypress driver. Unplug the NANO if it is connected to the PC. Reboot the PC.

Plug in the NANO to the USB port. The “USB to UART Adapter” will reappear. Try to update the driver again using Windows Update. For the desktop system windows update found a Cypress driver. I installed it and rebooted the PC. Device Manager now showed the “Other Devices” with the “Virtual Serial Port Device” in that section. As with the laptop I right clicked and updated the driver via Windows Update. A reboot then reconnected the NANO and started the Saver software. It worked.

How long will this last? Who knows? Until another major update like 20H2 I guess. 20H2 sounds like a virus. Oh wait… Windows is a virus…..

Mike

UlrichKraft 2021/04/12 22:56

Mike,
Wonderful !!

Let me know how you managed to get it to work. Obviously there are secret ways.....

Ulrich


⁣TypeApp for Android herunterladen ​

Am 12. Apr. 2021, 18:39, um 18:39, Mike Suhar <msuhar57@gmail.com> schrieb:

Roger 2021/04/13 08:17

That is the solution!
First: the Crypress drives and installed in Program Files (86)
Second: vna_qt.exe (for Windows) and installed in Program Files (86)

Kit 2021/04/13 16:15

Hi Team,
I also installed the Cypress driver and the .exe for a successful install on my Win-10 Dell Inspiron-15. Just placed the zip file into a new folder in 'Documents' folder - no special location.   Then made a short-cut from the vna_qt.exe to the desktop for launch.
Kitski

Kit 2021/04/13 16:34

This fix also worked for me (Win-10, Dell Inspiron laptop).  Just needed to make a desktop shortcut for the .exe for convenience.
(Unsure what happened to my previous post on this topic ... )
Cheers,

Kitski
VK1LL

Joe Smith 2021/04/14 09:16

I am currently using the Microsoft driver 10.0.18362.1.  I tried the Cypress driver 3.13.0.59 and saw no difference so I uninstalled it and went back to the one included with the OS.  I am running 10 Pro 10.0.18361 Build 18362.

I wonder if the problems people are running into started with later versions of the OS or if something else is causing it.

Mike Suhar 2021/04/14 11:47

For me it started with the upgrade of Windows 10 to Version 20H2,  Run "winver" and it will show you your current version.

Mike

ok1vaw 2021/05/01 11:02

I have to confirm incompatibility of NanoVNA Saver 0.3.8 with V2 Plus 4. As above mentioned, with my old V2 both programs (QT and Saver 0.3.8) are working, with new V2 Plus 4 (received just few days ago) only the QT works.  I see that the new COM port is assigned (in my case COM8), the QT works too, but the NanoVNA Saver *DOES NOT WORK with V2 Plus4*.
In the NanoVNA Saver 0.3.8 the serial port window remains blank, pushing Rescan button does nothing,  above-mentioned idea from OWO to write directly COM port to the window does not help too.
So I am convinced, that the *compatibility problem is in NanoVNA saver 0.3.8.*

Robert Mueller 2021/05/01 21:07

I had a similar "discovery". In Win 10 I was advised to load a Cypess
driver for the ThinkPad Laptop but when looking in the device manager it
appears to me (not the greatest for dealing with the deeper levels of
hardware) there it is marked that there is something to do with Intel at
the USB drivers. While I believe the USB ought to be Universal at that
external plug to the VNA, I fear there are not such universal rules at the
interface of the computer internal hardware and just cramming a Cypress
driver into the Laptop will just cause a need to repair who knows what will
suffer. Meanwhile, on a Win 7 running laptopthe VNA works with nanoVNA _qt
on both the Plus 4 and another VNA will poorer specs which also refused to
talk to Win 10 / Intel. There was no fooling around and wasting time.
Everything went on the first try.

The following is speculation so feel free to correct me and my guesses but
I suspect that Microsoft / Intel decide absolutely Universal is not
required; they may have ignored some service which was common in the
distant past but that the VNA depends on that service. In the past, I had
a problem with a Canon flatbed scanner which a newer computer refused to
accept although the Canon still worked on an older computer. To me this is
a betrayal to the idea of the bus being universal. At the consumer end it
may have to retain more or less out of date procedures because a fair
number of buyers of more modern computers may have no need to throw money
at new hardware, or worse, in some cases the old stuff does something
useful but nobody sells new equipment quite able to do the job, and that is
even more true with software which does not run on new operating systems.
Here the "modernization" is making trouble for a brand new device.

Anyway, my plan is to dedicate an older computer to measuring (and running
perfectly satisfactory older software) until I learn that teaching the
Intel part to do Cypress procedures really is safe.
If there is a better explanation I would be happy to learn it..

On Sat, May 1, 2021 at 8:02 PM ok1vaw <ok1vaw@volny.cz> wrote:

Barry - GM4TOE 2021/05/02 09:38

If you look at the post by 0w0 on the topic “You just lost the game” you will find that he has provided a firmware update (showed as “Experimental” when I downloaded it).
I installed this onto my new NanoVNA V2 Plus4 and the Windoze 10 problems with VNAsaver went away – i.e. the VNA now worked.

Robert Mueller 2021/05/02 10:55

Is this problem one caused entirely by Win 10 or is part of it the hardware
at the USB? And for those who scrapped the computer along with earlier
Windows versions, there is a problem; Win 10 and the VNA refuse to talk to
each other, or is that only for the software and not true for a firmware
update?.

On Sun, May 2, 2021 at 10:39 AM Barry - GM4TOE <barryhorning@btconnect.com>
wrote:

Dave (G1OGY) 2021/05/02 21:16

I think it may well be possible that it is a version issue with
Windows® 10 and the -Saver software.

I have two elderly Core 2 Duo laptops from the Vista era both are Dell
but different models. They are `good enough`.
One runs both -QT AND -Saver but has a previously installed Cypress
driver from another project (the NanoVNA `just worked` with both -QT
and -Saver), the machine has Intel ICH8 USB hardware:
Windows
Version 2004 (OS Build 19041.928)

The later, Business-class, machine - which will not run -Saver - no
COM ports detected (in addition there are two virtual COM ports on
this machine) - QT detects them all.
This machine has the Cypress driver from NanoRFE download page and
Intel ICH9 USB kit:
Windows
Version 20H2 (OS Build 19042.928)

Of course, it is entirely possible that the difference in USB hardware
is at the nub of the matter.
Bearing in mind that these are fairly old machines - no doubt Intel
USB has moved on - the (possibly) different drivers and the definitely
different Windows version makes me think: Perhaps I should try the
previously obtained Cypress driver on the recalcitrant machine?

Maybe more factual reports here - with hardware and software versions
included - may help the developers come to a resolution of the issue.

Dave, G1OGY

On Sun, 2 May 2021 at 09:55, Robert Mueller <robertmueller2000@gmail.com> wrote:

Robert Mueller 2021/05/02 22:25

Thanks, Dave; this suggests there is a problem which might be avoided if
better understood. and maybe making life easier in the future.

On Sun, May 2, 2021 at 10:17 PM Dave (G1OGY) <g1ogy@g1ogy.com> wrote:

To reply to this topic, join https://groups.io/g/NanoVNAV2

View this thread on groups.io