NanoVNA V2 / Forum

Note: this page is a mirror of https://groups.io/g/NanoVNAV2.
Click here to join and see most recent posts.

NanoVNA V2 plus 4 connetion with the PC-SW


Albrecht Debelak 2022/01/13 17:41

Hello NanoVNA V2 plus 4 users,

who of you has a NanoVNA V2 PLUS4 v2.4 with the PC (Win10) SW Nanavna-QT
(version 20200507) or Nano-Saver (3.8 or 3.10) in use?

Which FW is on the NanoVNA V2 PLUS4 v2.4?

Are you having problems establishing a connection?

Thanks and Greetings

Albrecht

Dominique GUEHO 2022/01/14 02:39

Yes Albrecht, I have received a NanoVna V2 PLUS 4 (FW: version: 20210530 - 412578c). I had no problem connecting with Nanovna QT (last version), but when you try to connect with Nano vna saver (3.9 or 3.10), it does not work, unless connecting first to nanovna QT and then connecting to NanoVna saver (3;9 or 2.10). The "trick" has been given by someone in this forum.

I work only with nanovna saver and so it is more complicated (till the correction of the bug) .... but it is possible !

Kenneth Goodwin 2022/01/14 10:12

nanovna-v2-02210726-v2plus4.bin which loaded Version: git-20210530-412578c Build Time: Jul 26 2021 When I look at my device menu options CONFIG --> VERSION only Version: git-20210530-412578c Build Time: Jul 26 2021 is displayed by the device.  Without any problems I am using NanoVNASaver version 0.3.10 and Nano vna_qt which has no known version display that I can find but the vna_qt.exe file has a file date of 5/7/2020 which I downloaded from the Windows version labled 20200507.  I use Windows 10 Pro 64-bit operating system on my computer.  From your past postings it seems as if you have used the same files including the Cypress device installer but my newbie guess would be that your problem is with the USB interface, maybe a possible USB port conflict??  A prolblem like this should be displayed in the Device Manager with a detail note indicating that the attempted interface is not working.  Just guessing.  I use USBDeview from Nirsoft.net to diagnose my usb interfaces. With my NanoVNA V2Plus 4 connected to my computer, the USB Serial Port (COM8 for me) is established while USBDeview shows Device Name: CDC-ACM Demo as a USB to UART Adapter with a Serial Number: DEMO.  When I put the NanoVNA V2Plus 4 into the Bootload configuration (no longer labeled DFU mode in the Config display, the available documentation is out of date for the NanoVNA V2Plus 4) to update the firmware, a new USB interface is established at COM7 for me and USBDeview shows that the previously established interface at COM8 as no longer connected.  The now connected Bootload interface at COM7 (for me), has a Serial Number USB_DFU whereas the earlier USB interface at COM8 had a displayed Serial Number DEMO in the USBDiview listing.   I find the change in the Windows computer Device Manager Ports (COM & LPT) listing from COM8 to COM7 as interesting noting that when I exit the Bootload mode back to the normal configuration, the connection is re-established back to COM8.  For reasons I don't fully comprehend, USBDeview doesn't display the COM ports but the documentation tells me for certain 'drivers' this could be the case.

Soapbox:  A side question for you, how do you know that you have a NanoVNA V2Plus 4 v2.4 ??  The only place I can find the label v2.4 of my recently purchased device is on the bill of sale.  I believe both of us have v2.4 but I guess you have to take it on faith backed up by using the firmware that is delineated for v2.4  I surely haven't used the v2.3 files.  I find that only the file dates and/or names have any hint as to their version in some cases.  For example, when I go to Config --> Version it displays NanoVNA V2Plus4 without any hint of it being NanoVNA V2Plus4 v2.4   I find the hardware and software versions all very confusing but I came from a profession with some very stringent configuration controls and even then we ended up with some very famous accidents because of configuration issues.

Kenneth Goodwin 2022/01/14 11:04

As an additional thought on your issue based on my wild guess as to a COM port, both Nano vna_qt View and Nano-Saver should initially execute without a NanoVNA V2Plus4 connected to your computer. If they crash upon initial execution without a NanoVNA V2Plus4 connected to your computer, I would suspect you have a Windows problem.  Without a NanoVNA V2Plus4 connected to your computer, Nano vna_qt doesn't show a viable COM port under the Device menu and Nano-Saver does nothing when the Connect to Device button is clicked but they both initially execute. I've probably misread your situation but I've had no problems with what seems to be the same configuration as yours.

Dominique GUEHO 2022/01/14 22:59

To complete the description of my context:

- I am pretty sure I have bought a nanovna V2 Plus 4 (bought on Tindie store.... The hardware in a metal - blue.grey-  housing.... like the photo -  etc... OR you can never trust anybody !!)

- When CONFIG - Version it does NOT display the same number as the official number of the FW. It induces a lot of questions for NOTHING and why not correct the problem ? Or Why is it necessary to have two different numbers for the same thing ?
- When I open Nanovna QT or Nanovna Saver, the nanovna NOT being "USB connected", no problem the softwares both open

- When Nanovna is "USB connected" Nano vna QT opens and connects when clicking the number of the usb port.... It works correctly

- When Nanovna is "USB connected" Nano vna Saver opens and when I click on "CONNECT" Nanovna Saver Crashes immediatly (Except if I do these things "in sequence" - First Nanovna QT, second Nanovna Saver)

canale 2022/01/16 02:33

Hi, Dominique
I had the same problem and I solved it updating the firmware in the VNA
Regards
Gianfranco

Dominique GUEHO 2022/01/16 15:00

Yes Gianfranco, with which version of the FW have you updated ? Mine is
20210530-412578 (CONFIG/VERSION)

PS: Sei italiano ?


Le 16/01/2022 à 11:33, canale via groups.io a écrit :
> Hi, Dominique
> I had the same problem and I solved it updating the firmware in the VNA
> Regards
> Gianfranco
>
--
Dominique GUEHO

Albrecht Debelak 2022/01/16 18:26

Hello,

thank you for your tips and your information.
I just wanted to know for sure whether the NanoVna V2 puls 4 device also
works with the two PC SW Nanovna-QT and Nanovna-Saver.
I think the PC HW and the Windows 10 version with the Cypress driver
also have an influence on a stable function or the possibility of
carrying out a FW update.
It worked for me a couple of times and then it didn't.
I could not carry out a FW update with the NanoVNA - QT.
I have a similar behavior with three different PCs.
I probably have a defect on the NanoVna V2 puls 4 USB interfaces and
that's why I ordered a new device.
greetings and thanks
Albrecht

Am 16.01.2022 um 15:00 schrieb Dominique GUEHO:

Kenneth Goodwin 2022/01/16 10:33

The only valid version label of the firmware is the one displayed by the device itself Config --> Version --> git-20210530-412578c I just love how 20210530 (May 30 2021) produces a Build Date of 20210726 which is displayed as July 26 2021. Must be a slow compiler if it takes two months to produce a valid build. Obviously I don't understand something here.  Thus to me it seems as if the websites follow a pick-your-own-name protocol which does nothing but confuse me also.

The oddity of doing a firmware update is that the USB Com port is changed when Config --> Bootload --> Reset and Enter is executed which puts the device into the Device Firmware Update Mode (DFU). As an example (just for my PC's configuration), when I first connect the device to my PC, the correct COM port presented to Nano vna_qt is COM 8. If I select this port before getting into the DFU mode, the device goes into the USB Mode and there is no way to do a firmware update.  If on the other hand, I connect the device to the PC, enter the firmware update mode (Config --> Bootload --> Reset and Enter) and then connect Nano vna_qt, the correct COM port presented to Nano vna_qt which in my case is now COM 7 since COM 8 has been disconnected and COM 7 has been established.  Then when I start Nano vna_qt, connect to the correct COM port which is now COM 7 (COM 8 is no longer displayed), Nano vna_qt will start with a display --> Device is in the DFU mode.  Flash a new firmware? This is probably common knowledge to you but for guys like me who started programming with 1's and 0's, it is all new and confusing ground.

Vladimir Lebedev 2022/01/16 11:23

Hello Kenneth!

FW 20210726 has internel version number 20210530.
Load please 20210726.bin in Notepad. I found this:

Version: git-20210530-412578c   Build Time: Jul 26 2021 - 10:55:59 :

FW 20210726 = FW 20210530 ?

Wont You other version number, please load FW from 12/27/2021
https://nanorfe.com/downloads/20211227/nanovna-v2-20211227-v2plus4.bin
Yes, an experimental firmware, but the newest. Internel :

Version: 20211227   Build Time: Dec 27 2021 - 06:28:40

Best regards
Vladimir, dl7pga

To reply to this topic, join https://groups.io/g/NanoVNAV2

View this thread on groups.io