NanoVNA V2 / Forum

Note: this page is a mirror of https://groups.io/g/NanoVNAV2.
Click here to join and see most recent posts.

NANO-QT Software


Alan Scott 2021/03/27 22:55

Hey all,

Trying to get Nano-QT running. Have the device drive installed etc and get the error:

Xavna_read_atutosweep Failed: Resource deadlock avoided

On the research I have done it says to disable "data validation" in the device settings. I'm running on Windows 10 and I see no option for this.

Can I please have some more direction on how to fix this error?

If you require any information, please let me know.

With thanks


If you require any help, please let me know.

With thanks

Alan Scott | Director
Technology Problem? Solved.
Logical Solutions
120 Comries Road, Hamilton, 3210
Tele: 07 929 2200 Ext. 4040
Fax: 07 929 2201
Mail: Alan.Scott@logicalsolutions.co.nz<mailto:Alan.Scott@logicalsolutions.co.nz>
Web: www.logicalsolutions.co.nz<http://www.logicalsolutions.co.nz/>
[Logical-solutions-sig]

David Eckhardt 2021/03/28 16:11

You're not alone. I have never been able to vconnect my V2N to the PC or
QT. I'm also using WIN 10, 64. However, it does make an excellent
stand-alone instrument.

Dave - WØLEV

On Sun, Mar 28, 2021 at 3:34 AM Alan Scott <
alan.scott@logicalsolutions.co.nz> wrote:

> Hey all,
>
>
>
> Trying to get Nano-QT running. Have the device drive installed etc and get
> the error:
>
>
>
> Xavna_read_atutosweep Failed: Resource deadlock avoided
>
>
>
> On the research I have done it says to disable “data validation” in the
> device settings. I’m running on Windows 10 and I see no option for this.
>
>
>
> Can I please have some more direction on how to fix this error?
>
>
>
> If you require any information, please let me know.
>
>
>
> With thanks
>
>
>
>
>
> If you require any help, please let me know.
>
>
>
> With thanks
>
>
>
> *Alan Scott *| Director
>
> *Technology Problem? Solved.*
>
> Logical Solutions
>
> 120 Comries Road, Hamilton, 3210
>
> Tele: 07 929 2200 Ext. 4040
> Fax: 07 929 2201
>
> Mail: *Alan.Scott@logicalsolutions.co.nz
> <Alan.Scott@logicalsolutions.co.nz>*
>
> Web: *www.logicalsolutions.co.nz <http://www.logicalsolutions.co.nz/>*
> [image: Logical-solutions-sig]
>
>
>
>
>

--
*Dave - WØLEV*
*Just Let Darwin Work*

Siegfried Jackstien 2021/03/28 20:48

hmm that is unusual .. if you installed the cypress driver ... then your
nano v2 should work with THREE software

nanovna saver

vna qt

nanovna_app

all three work fine with the v2, v2plus, v2plus4 (i have all three and
can confirm that)

saver and qt do not like if you have AVG not set to none ... explain
why?? ok ... if you (as an example) set avg to 5 ... and software asks
for 100 points .. it gets only 20 points back and stops with a timeout error

nanovna app does not care about avg setting IN the device (only scanning
then is slower) ...

so for the first two soft you have to set AVG to none .. and save that
in calibration slot 0 (cause that is default when switch on)

good luck dave ... and feel free to ask if you still have problems

greetz sigi dg9bfc

Am 28.03.2021 um 16:11 schrieb David Eckhardt:

Bill Smith 2021/03/28 14:49

saver and qt do not like if you have AVG not set to none

so for the first two soft you have to set AVG to none

?? Sign of the crazy times.;..



_____

From: NanoVNAV2@groups.io [mailto:NanoVNAV2@groups.io] On Behalf Of
Siegfried Jackstien
Sent: Sunday, March 28, 2021 1:48 PM
To: NanoVNAV2@groups.io
Subject: Re: [nanovnav2] NANO-QT Software



hmm that is unusual .. if you installed the cypress driver ... then your
nano v2 should work with THREE software

nanovna saver

vna qt

nanovna_app

all three work fine with the v2, v2plus, v2plus4 (i have all three and can
confirm that)

saver and qt do not like if you have AVG not set to none ... explain why??
ok ... if you (as an example) set avg to 5 ... and software asks for 100
points .. it gets only 20 points back and stops with a timeout error

nanovna app does not care about avg setting IN the device (only scanning
then is slower) ...

so for the first two soft you have to set AVG to none .. and save that in
calibration slot 0 (cause that is default when switch on)

good luck dave ... and feel free to ask if you still have problems

greetz sigi dg9bfc

Am 28.03.2021 um 16:11 schrieb David Eckhardt:

You're not alone. I have never been able to vconnect my V2N to the PC or
QT. I'm also using WIN 10, 64. However, it does make an excellent
stand-alone instrument.



Dave - WØLEV



On Sun, Mar 28, 2021 at 3:34 AM Alan Scott
<alan.scott@logicalsolutions.co.nz> wrote:

Hey all,



Trying to get Nano-QT running. Have the device drive installed etc and get
the error:



Xavna_read_atutosweep Failed: Resource deadlock avoided



On the research I have done it says to disable “data validation” in the
device settings. I’m running on Windows 10 and I see no option for this.



Can I please have some more direction on how to fix this error?



If you require any information, please let me know.



With thanks





If you require any help, please let me know.



With thanks



Alan Scott | Director

Technology Problem? Solved.

Logical Solutions

120 Comries Road, Hamilton, 3210

Tele: 07 929 2200 Ext. 4040
Fax: 07 929 2201

Mail: Alan.Scott@logicalsolutions.co.nz

Web: <http://www.logicalsolutions.co.nz/> www.logicalsolutions.co.nz
Logical-solutions-sig





--

Dave - WØLEV

Just Let Darwin Work

David Eckhardt 2021/03/28 23:07

I downloaded from the URL:https://nanorfe.com/nanovna-v2-software.html
First: the Crypress drives and installed in Program Files (86)
Second: vna_qt.exe (for Windows) and installed in Program Files
(86)

then launch vna-qt.exe

The expected window opens, but I seem totally unable to connect to the V2
VNA.

On checking under DEVICE: and //./COM1 or under "OTHER" within
DEVICE and input //./COM4 I receive the following error message:

[image: image.png]
[image: image.png]
which reads:

[image: image.png]

How do I connect to this V2 device.

Dave - WØLEV




On Sun, Mar 28, 2021 at 8:48 PM Siegfried Jackstien <
siegfried.jackstien@freenet.de> wrote:

> hmm that is unusual .. if you installed the cypress driver ... then your
> nano v2 should work with THREE software
>
> nanovna saver
>
> vna qt
>
> nanovna_app
>
> all three work fine with the v2, v2plus, v2plus4 (i have all three and can
> confirm that)
>
> saver and qt do not like if you have AVG not set to none ... explain why??
> ok ... if you (as an example) set avg to 5 ... and software asks for 100
> points .. it gets only 20 points back and stops with a timeout error
>
> nanovna app does not care about avg setting IN the device (only scanning
> then is slower) ...
>
> so for the first two soft you have to set AVG to none .. and save that in
> calibration slot 0 (cause that is default when switch on)
>
> good luck dave ... and feel free to ask if you still have problems
>
> greetz sigi dg9bfc
> Am 28.03.2021 um 16:11 schrieb David Eckhardt:
>
> You're not alone. I have never been able to vconnect my V2N to the PC or
> QT. I'm also using WIN 10, 64. However, it does make an excellent
> stand-alone instrument.
>
> Dave - WØLEV
>
> On Sun, Mar 28, 2021 at 3:34 AM Alan Scott <
> alan.scott@logicalsolutions.co.nz> wrote:
>
>> Hey all,
>>
>>
>>
>> Trying to get Nano-QT running. Have the device drive installed etc and
>> get the error:
>>
>>
>>
>> Xavna_read_atutosweep Failed: Resource deadlock avoided
>>
>>
>>
>> On the research I have done it says to disable “data validation” in the
>> device settings. I’m running on Windows 10 and I see no option for this.
>>
>>
>>
>> Can I please have some more direction on how to fix this error?
>>
>>
>>
>> If you require any information, please let me know.
>>
>>
>>
>> With thanks
>>
>>
>>
>>
>>
>> If you require any help, please let me know.
>>
>>
>>
>> With thanks
>>
>>
>>
>> *Alan Scott *| Director
>>
>> *Technology Problem? Solved.*
>>
>> Logical Solutions
>>
>> 120 Comries Road, Hamilton, 3210
>>
>> Tele: 07 929 2200 Ext. 4040
>> Fax: 07 929 2201
>>
>> Mail: *Alan.Scott@logicalsolutions.co.nz
>> <Alan.Scott@logicalsolutions.co.nz>*
>>
>> Web: *www.logicalsolutions.co.nz <http://www.logicalsolutions.co.nz/>*
>> [image: Logical-solutions-sig]
>>
>>
>>
>
>
> --
> *Dave - WØLEV*
> *Just Let Darwin Work*
>
>
>
>

--
*Dave - WØLEV*
*Just Let Darwin Work*

Siegfried Jackstien 2021/03/28 23:27

set avg to none in the device and save in slot 0

then it should work

nanovna safer ... and vna qt ... do not work if avg is NOT set to none

soft asks for 100 points but gets 50 back(with avg x2) or only 20 (with
avg set to x5) ... so you need to switch average off in the device when
using with pc (inside the pc soft you then can add averaging to have
smoother curves)

i have THREE different nanov2 ... v2 modded with 4 inch, v2plus with 4
inch (modded saa2n) and a plus4

ALL THREE work with THREE pc software (vna qt, nanovna safer and
nanovna_app)

i prefer last one (nanovna app) cause its the most comfordable soft in
my view and also does fw update like the qt software does

plus it can do screenshots from the devices screen (see picture)

also nice is that this last one ... works with or without setting avg to
none in the device (only scan speed lowers when using avg x2, x5,
whatever) ...

greetz sigi dg9bfc

Am 28.03.2021 um 23:07 schrieb David Eckhardt:

Alan Scott 2021/03/28 23:29

I spent most of yesterday working on this!

What I learned is that there are many, many Nano V2’s on the market. I would say most of them are CLONES and not compatible with the VNA_QT software.

For instance, I have the Nano F V2 – it seems that this is one of the most common but is not a TRUE V2. (I got caught out as well)



If you require any further information, do not hesitate to contact me.

With thanks

-Alan Scott

David Eckhardt 2021/03/28 23:30

I connect through a known good USB cable with the appropriate connectors.

Dave

On Sun, Mar 28, 2021 at 11:07 PM David Eckhardt via groups.io <davearea51a=
gmail.com@groups.io> wrote:

> I downloaded from the URL:https://nanorfe.com/nanovna-v2-software.html
> First: the Crypress drives and installed in Program Files (86)
> Second: vna_qt.exe (for Windows) and installed in Program Files
> (86)
>
> then launch vna-qt.exe
>
> The expected window opens, but I seem totally unable to connect to the V2
> VNA.
>
> On checking under DEVICE: and //./COM1 or under "OTHER" within
> DEVICE and input //./COM4 I receive the following error message:
>
> [image: image.png]
> [image: image.png]
> which reads:
>
> [image: image.png]
>
> How do I connect to this V2 device.
>
> Dave - WØLEV
>
>
>
>
> On Sun, Mar 28, 2021 at 8:48 PM Siegfried Jackstien <
> siegfried.jackstien@freenet.de> wrote:
>
>> hmm that is unusual .. if you installed the cypress driver ... then your
>> nano v2 should work with THREE software
>>
>> nanovna saver
>>
>> vna qt
>>
>> nanovna_app
>>
>> all three work fine with the v2, v2plus, v2plus4 (i have all three and
>> can confirm that)
>>
>> saver and qt do not like if you have AVG not set to none ... explain
>> why?? ok ... if you (as an example) set avg to 5 ... and software asks for
>> 100 points .. it gets only 20 points back and stops with a timeout error
>>
>> nanovna app does not care about avg setting IN the device (only scanning
>> then is slower) ...
>>
>> so for the first two soft you have to set AVG to none .. and save that in
>> calibration slot 0 (cause that is default when switch on)
>>
>> good luck dave ... and feel free to ask if you still have problems
>>
>> greetz sigi dg9bfc
>> Am 28.03.2021 um 16:11 schrieb David Eckhardt:
>>
>> You're not alone. I have never been able to vconnect my V2N to the PC or
>> QT. I'm also using WIN 10, 64. However, it does make an excellent
>> stand-alone instrument.
>>
>> Dave - WØLEV
>>
>> On Sun, Mar 28, 2021 at 3:34 AM Alan Scott <
>> alan.scott@logicalsolutions.co.nz> wrote:
>>
>>> Hey all,
>>>
>>>
>>>
>>> Trying to get Nano-QT running. Have the device drive installed etc and
>>> get the error:
>>>
>>>
>>>
>>> Xavna_read_atutosweep Failed: Resource deadlock avoided
>>>
>>>
>>>
>>> On the research I have done it says to disable “data validation” in the
>>> device settings. I’m running on Windows 10 and I see no option for this.
>>>
>>>
>>>
>>> Can I please have some more direction on how to fix this error?
>>>
>>>
>>>
>>> If you require any information, please let me know.
>>>
>>>
>>>
>>> With thanks
>>>
>>>
>>>
>>>
>>>
>>> If you require any help, please let me know.
>>>
>>>
>>>
>>> With thanks
>>>
>>>
>>>
>>> *Alan Scott *| Director
>>>
>>> *Technology Problem? Solved.*
>>>
>>> Logical Solutions
>>>
>>> 120 Comries Road, Hamilton, 3210
>>>
>>> Tele: 07 929 2200 Ext. 4040
>>> Fax: 07 929 2201
>>>
>>> Mail: *Alan.Scott@logicalsolutions.co.nz
>>> <Alan.Scott@logicalsolutions.co.nz>*
>>>
>>> Web: *www.logicalsolutions.co.nz <http://www.logicalsolutions.co.nz/>*
>>> [image: Logical-solutions-sig]
>>>
>>>
>>>
>>
>>
>> --
>> *Dave - WØLEV*
>> *Just Let Darwin Work*
>>
>>
>
> --
> *Dave - WØLEV*
> *Just Let Darwin Work*
>
>
>
>

--
*Dave - WØLEV*
*Just Let Darwin Work*

Alan Scott 2021/03/28 23:32

Take a picture of your V2 VNA.



If you require any further information, do not hesitate to contact me.

With thanks

-Alan Scott

C.M. 2021/03/28 17:25

Alan,

If your unit is a F-v2, you can find the appropriate resources from below group:
NanoVNA-F v2 ( https://groups.io/g/nanovna-f-v2 )

Cheers
CM

Robert Mueller 2021/04/02 16:54

The command "avg" is not in all versions of firmware; is there some
alternative which can get the same benefit? I have looked at every
command in one menu (20200501) and it is simply absent.

Bob Mueller

On Mon, Mar 29, 2021 at 6:15 AM Bill Smith <wbs@hbco2.com> wrote:

To reply to this topic, join https://groups.io/g/NanoVNAV2

View this thread on groups.io