Beware of cheap underperforming clones

As of 2022 there are many badly performing clones on the market. V2/3GHz NanoVNA uses parts like ADF4350 and AD8342 which are costly and clones have been cutting costs by using salvaged or reject parts.

See official store and look for V2 Plus4/V2 Plus4 Pro versions only to avoid getting a bad clone. We have stopped selling V2.2 versions since October 2020, so all V2 hardware that are not Plus or Plus4 are not made by us and we can not guarantee performance.

NanoVNA V2 Forum

Note: this page is a mirror of
Click here to join and see most recent posts.

I'm back to a scrambled screen mystery.

barnc4br 2020/12/23 20:51

After I perform an SOLT calibration 100MHz to 900MHz I get a crazy scrambled screen. The Smith Chart is bouncing all over the center of the screen. The other traces are sine waves of large varying amplitude. The yellow one goes off the screen. Nothing is connected. If I connect a short or cable to CH1, the screen freezes.
If I reset the cal data it goes back to an uncalibrated screen with flat traces. That defeats everything.
I can connect a test circuit and it shows me a reasonable picture, albeit uncalibrated.
I uploaded a screenshot to the files section = "scrambled screen"
Someone please tell me what I am doing wrong.

Louis Wilen 2020/12/23 23:55

I am seeing the same problem.  I'm not sure what I did to cause the
problem, but I've tried every type of reset that I can think of but the
unit won't return to normal operation.


On 12/23/2020 11:51 PM, wrote:

barnc4br 2020/12/24 09:17


Is it exactly the same unit V2.4 w/10/13/20 F/W?
Did it ever work correctly for you? If so when did it change?

If it is the same unit, you may be interested in my menu map. I think it is the only one for that specific version. It is in the file section.


Louis Wilen 2020/12/24 13:18


Yes, the unit worked fine for about a week.  I was running the
10/13/2020 FW when the behavior started.  I then tried reset, reset all,
and everything else I could think of.   Then I went back to the firmware
than the unit came with.  No change.


On 12/24/2020 12:17 PM, wrote:

Ken Sejkora 2020/12/24 14:07

Have you tried a ‘Reset All’, followed by ‘Reset’, and then save the “clean” configuration to Slot 0, before power cycling the device? Since the device “boots up” with whatever is in Slot 0, if that configuration is corrupted, it can cause problems. Resetting the unit and saving the reset configuration to Slot 0 **Might** help.

Good luck.


From: Louis Wilen
Sent: Thursday, December 24, 2020 01:18 PM
Subject: Re: [NanoVNAV2] I'm back to a scrambled screen mystery.


Yes, the unit worked fine for about a week.  I was running the
10/13/2020 FW when the behavior started.  I then tried reset, reset all,
and everything else I could think of.   Then I went back to the firmware
than the unit came with.  No change.


On 12/24/2020 12:17 PM, wrote:

barnc4br 2020/12/24 15:10

I just stumbled onto something...........
I just calibrated a previous config that was not
I went thru the call procedure again and had the same result connecting to my test board.
I started rummaging thru the menu again and realized APPLY had become checked - it was not previously.
I unchecked it and BOOM perfect.
I have no idea what that is suppose to do or why it gets set after a cal. Or why no one appears to have experienced it. I have seen reference to it someplace. I need to find it and see what I missed

make sure APPLY is not checked. Let me know if it works for you

DiSlord 2020/12/24 19:21

If disable calibration and all look ok then in 90% i thik you have bad 50Om load calibration kit (or bad cable/connectors)

DiSlord 2020/12/25 04:19

This mean in 0 slot at device startup - no any valid calibration data.
0 slot auto load at device start.

barnc4br 2020/12/26 20:51

Mine did it with any calibrated save I reloaded. It was the apply "feature" that I have no idea what it is. It gets checked on cal and saved. I unchecked it and everything was good -

barnc4br 2020/12/26 21:03

I would suggest doing a RESET ALL. That should set everything of concern to default. Then setup a frequency and a Trace for SMITH and LOGMAG then do a cal. The APPLY will be unchecked b4 you do it. When u finish with the cal and save it, the APPLY will be checked and it will scramble. If I go back to ANY of my saves and check APPLY the scramble comes back instantly. Enhanced response is not on by default but if it is on, turn it off. If you still have garbage it is above my pay grade.
I am having a problem verifying my cal, but I don't have enough to ask a question about it yet.

Louis Wilen 2020/12/27 01:51

Thanks for the reply.  I've done all those things but the problem remains.


On 12/27/2020 12:03 AM, wrote:

barnc4br 2020/12/27 06:24

So much for us dyslexic newbies. I again stumbled on my problem, which may be yours.
Have you tried to verify your calibration? What you may find, as I did, something is backwards.
It was verifying on the wrong port. Well, not really verifying. I had the ports backward. CH0 is on the RIGTH if the ports are UP.

It is perfect, I am not. But at least my wife knows that. Calibration is now "perfect".

barnc4br 2020/12/27 07:37

DiSlord - I just wanted to insure you saw this. Most of the problems I have had are with documentation and this one appears to extend to many. The scrambled screen effect, in my case, and I am betting in everyone's case, is do to the fact that I was calibrating CH1 instead of CH0. I had the ports confused. CH0 is on the right with ports facing up.

Louis Wilen 2020/12/27 11:26

Thanks for the suggestion but I am definitely calibrating CH0.  It's
labeled on the unit.

Everything was working fine for me for about a week and I got to know
the unit quite well.  Then the odd behavior suddenly started. I tried
going back and forth between new and old firmware, but that didn't help,


On 12/27/2020 9:24 AM, wrote:

barnc4br 2020/12/27 15:43

just for grins, try it backwards. I can't believe I was doing that. But I can't readily put my hands on a picture that shows CH0 & CH1. I was having problem trying to verify the cal because nothing happened when I put the stds on CH0, which wasn't CH0. When I put them on CH1, which obviously was CH0, I got a reaction. So I recalled that way and it is perfect. My CH0 is on the right with the ports up.

barnc4br 2020/12/29 05:42

In case someone is following this, it is not the solution. APPLY turns calibration correction on/off.
Therefore, that screen indicates a bad calibration. For me, I was doing it on the wrong port, really!!

John Cunliffe W7ZQ 2020/12/30 07:57

Could it be you have a problem with connectivity to the ports and that screws up your calibration? One of the units I have started to behave erratically after calibration and I found that there was a problem with the cheap SMA's used. I took a fine needle and pushed the inner contacts on the units SMA jacks back together and it fixed the problem. That problem took about 4 weeks before it showed up and your issue of working fine for 2 weeks reminds me of that. Also, check the solder connection of the SMA inner to the PC board. If the unit gets faulty information during cal it will scramble the screen.


Stephen Laurence 2020/12/30 08:23

I had a problem with one of my vnas some months ago. The cause was one of the two leaves of the sma port connector was bent. I knew straight away there was something wrong as it was difficult to line up the sma connectors.

My cheap Chinese “microscope” magnified the view nicely, and judicious use of an appropriate size sewing needle, first the sharp end then the eye end soon righted the problem.

When connecting up, I always inspect first, line up, then push the connectors together, then gently tighten the nut, rarely using a “wrench” (search for my previous posts on this and my home made 8mm spanner). Failure to do this every time will eventually cost you in replacing the connectors or the whole vna. Use “savers” or the extension cables supplied with the device as often as possible.

I also had “trouble” in my early days with my saa2N, thinking my cal load was faulty. I had crazy screens, usually the phase signal which appeared as I tightened up the load onto Port1 after calibration. It was actually normal, but the phase from 0 to 3.5ghz jittered a degree or two about zero giving lines all over the screen. Setting a few picoseconds of delay restored normality. It would take a while to explain......

I learn all the time.

Steve L

To reply to this topic, join