Beware of cheap underperforming clones

As of 2023 there are many badly performing clones on the market. V2/3GHz NanoVNA uses parts like ADF4350 and AD8342 which are costly and clones have been cutting costs by using salvaged or reject parts.

See official store and look for V2 Plus4/V2 Plus4 Pro versions only to avoid getting a bad clone. We have stopped selling V2.2 versions since October 2020, so all V2 hardware that are not Plus or Plus4 are not made by us and we can not guarantee performance.

NanoVNA V2 Forum

Note: this page is a mirror of
Click here to join and see most recent posts.

Blank screen after fitmware update

Russ G4SAQ 2023/05/23 10:38

I have just tried to update the firmware in my V2 Plus 4 to the latest version (20220814) using VNA_QT in Windows 11.   The VNA showed up as COM7 in QT and I pointed to my downloaded firmware bin file and started the process.  My VNA screen went completely white and it is unresponsive.  I have tried turning it on again whilst pressing the left hand button but this has no effect.
Is there a way of forcing a reset?  On the back of the LCD board, along the connector strip, there is the word "TOUCH" and white lines pointing to T_IRQ and T_CLK.  I wonder if this is used to produce a hardware reset but I want to be sure before causing further problems :-(   Any help gratefully received, thanks., Russ

Siegfried Jackstien 2023/05/24 20:14

i would try to update fw again (maybe on a different pc ??)

i use nanovna_app (for measure and for update) ... tested on saa2n (a v2
clone with 4 inch and n sockets) .. and on my vna v2plus4 (closed source
bootloader and different fw as a normal v2) ... on both units the update
of the fw was easy and worked "out of the box"

white screen?? so its in update mode ... but that did not work correct
in your case .. means unit stays in update till you fire on a working fw

dg9bfc sigi

Am 23.05.2023 um 19:38 schrieb Russ G4SAQ:

Russ G4SAQ 2023/05/26 03:04

Thanks Sigi but still not working.  I have tried different PCs and even installed Linux Debian on an old PC to try that.  The PCs are just not recognising the VNA as a valid USB device.  I would have hoped there was a hardware reset but it's not obvious if there is.
The data sheet for the GD32F303 describes a process for entering Bootloader mode by grounding 'BOOT0' (pin 20) and connecting 'BOOT1' (pin 44) to VDD.  I'm not brave enough to try this!  Especially as I can't find a schematic for the V2 Plus4.
Russ, G4SAQ

To reply to this topic, join

View this thread on