NanoVNA V2 Forum

Note: this page is a mirror of https://groups.io/g/NanoVNAV2.
Click here to join and see most recent posts.

4" display cannot select Touch Cal


Marcus Gustafsson 2020/09/06 08:25

Hi,

I wanted to swap to the 4" display from the 2.8" one. So I've built the firmware (btw I had to back a few revisions in order for it to build) with the DISPLAY_ST7796 define enabled and successfully loaded it to my unit.

However since the unit uses old screen cal data I cannot select the "Touch Cal" menu item?
Any advise besides building a new version with the menu option moved further down?

Best regards
Marcus

Siegfried Jackstien 2020/09/06 16:17

you can select that option (and all other functions) also with the 3
buttons ... select touch tune and then it should be fine

flipping display and a fresh touch tune helped here after first 4 inch
fw install (depending how far you stepped back there may be a bug)

dg9bfc sigi

Am 06.09.2020 um 15:25 schrieb Marcus Gustafsson:

Siegfried Jackstien 2020/09/06 16:19

did you try this one??

https://github.com/douardda/NanoVNA-V2-firmware/releases/tag/20200905

dg9bfc sigi

Am 06.09.2020 um 15:25 schrieb Marcus Gustafsson:

Stephen Laurence 2020/09/06 09:20

I might be able to help.

I actually posted about this a few weeks ago, but it was not for the 4” screen, but a plug and play 3.2” inch to replace the 2.8” one.

The screen lit up ok but I could not use touch. Despite the modest increase in screen size, it was so much easier to read, so I persevered.

I TRIED to navigate to the screen calibration routine but I had to use the three buttons and it took some time. Then the calibration did not make any difference. After navigating to the screen calibration with the buttons for the 4th time, I tried this...

When it said to touch the top left, I touched the bottom right, and then when it said touch bottom right, I touched top left.
All then well.

Do not forget to press save on the touch-sensitive screen or you will have to do it all again the next time yo7 switch on.

Alternatively, try to use the firmware for the v2N version, which uses the 4” screen with the bog standard V2 board.

Steve L. G7PSZ

Marcus Gustafsson 2020/09/06 11:03

Hi all,

I solved by adding the "Touch Cal" menu item last in that menu. But using the buttons would have been much easier. Now I know that. Thanks

Also thanks for the pointer to binary releases by douardda. I'm now running that version instead.

Br
Marcus

Siegfried Jackstien 2020/09/06 22:32

with the new release that touch thingy is solved ...

dg9bfc sigi

Am 06.09.2020 um 16:20 schrieb Stephen Laurence:

To reply to this topic, join https://groups.io/g/NanoVNAV2

View this thread on groups.io